IEmail v3 User Guide & Installation
Manual

Last updated August 2024

iEmalil is a utility that integrates Microsoft Outlook™ with the iIMIS membership database. It enables
staff to search the iMIS database for email addresses, log outgoing and incoming emails as IMIS
activities, and synchronise Tasks and Appointments between iMIS and Outlook.
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1. iIEmail Overview

iEmail is a utility that integrates Outlook™ with your iMIS database. Key capabilities include:

» Search the iMIS database for email addresses and add them to the To, Cc, or Bcc fields in Outlook.

* Insert emails directly into iMIS as activities, along with text and attachments. You may insert at send time or
after an email has been sent or received.

 Import Tasks and Appointments from iMIS into Outlook's Tasks and Calendar.

* Allow the System Administrator to limit user access and set maximum recipient counts (iIEmail is not a
mass-emailing tool).

Note: This guide covers iEmail v3. Support for iIEmail v2 ended July 1, 2022. If you need to upgrade, email
support.imis.com.

Important: Microsoft's New Outlook does NOT support COM Add-ins. iEmail is a COM Add-in and will not run
under New Outlook. The cloud-based replacement is iEmail Cloud (docs.csiinc.com/iemail-cloud/).

2. System Requirements

IEmail Web Services (Server)

SQL Server 2008R2 /2012 / 2014 (32-bit and 64-bit)
RAM 1,024 MB minimum

Disk space 100 MB free

.NET Framework v4.6.2

IEmail Client (Workstation)

oS Windows 10 or higher

Outlook Microsoft Outlook 2016 or higher (not O365 web interface)
iMIS 15.2, 20.1, 20.2 (2017)

RAM 1,024 MB minimum

Disk space 100 MB free

.NET Framework v4.6.2
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Note: Installation assumes a default environment (Default Website, Port 80 open, no unusual firewall
restrictions). Non-standard configurations are outside the standard support agreement and may be billable.

3. Architecture — Three Components

iEmail v3 is composed of three separate programs that must all be installed and kept at matching major/minor

versions:
1 iEmail IQA Web Service On the iMIS casual-view web server (same folder as iMIS)
2 iIEmail Web Services On the application/web server with 1IS and SQL access
3 iEmail Client (COM Add-in) On each workstation running Outlook

Note: Licensing for iEmail v3 is per-user. You must add the role CSI-iEmail in iMIS and assign it to each
licensed user.

4. Installing iEmail for the First Time

Step 1: Configure Your Application/Web Server

Install 11IS 6 Management Compatibility components. The required sub-feature is IIS 6 Metabase Compatibility.
Procedure varies by OS:

Windows Server 2012 or higher — Server Manager:
1. Click Start > Windows Administrative Tools > Server Manager.

2. From the dashboard select Add Roles and Features.

3. Ensure Role-Based or Feature-based installation is selected. Click Next.

4. Expand Web Server (1IS) > Management Tools > 1IS Management Compatibility.

5. Select 1IS 6 Metabase Compatibility, IIS 6 Management Console, and 1IS 6 WMI Compatibility.
6. Click Next on the Features screen without changes.

7. Click Install, then Close.

Step 2: Install iEmail (IQA) Web Services

The IQA web service must reside on the same server as the iMIS casual website.

1. Unzip the iEmail installation files received from ASI/CSI.
2. Browse to the folder Web Services IQA.
3. Run iEmail Webservices Deployment IQA Setup and click through the wizard.
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4. Run the installed iEmail Web Services Deployment IQA program.
5. Enter the physical path to the iMIS casual website (include \NET at the end of the path).
6. Enter the iMIS Staff website URL (exclude /CS at the end). Click Browse URL to verify.

7. Click Install. You should receive '"Web service was successfully installed." Allow iMIS to restart.

Important: iIMIS will restart at the completion of the IQA installation. Ensure no users are working in iMIS
during this step.

Step 3: Install the iEmail v3 Web Services Deployment Program

From the Web Services folder, double-click iEmail Webservices Deployment Setup and complete the wizard.
Then launch the deployment program from Start > CSI Programs.

In the deployment tool, configure the following fields:

Website Default Website (highly recommended)

Virtual Directory iIEmailWebServices (recommended default)

Application Pool iEmail App Pool (recommended default)

Physical Location C:\inetpub\iEmailWebServices (recommended default)

iMIS Web Server URL Your iMIS staff site URL — must start with HTTPS:// — exclude /CS
Database Server Name SQL Server hosting iMIS

Database User Name SQL Administrator username (not your iMIS username)

Database Password SQL Administrator password

Database Name The iMIS database name

Click Validate Database — the button turns green when successful. Then click Update to create the web service.
Allow 1-2 minutes to complete.

Note: You may get a timeout error on the iMIS Web Server URL. Wait 1 minute and retry. If it fails, verify the
URL opens in a browser (using HTTPS).

Step 4: Install SSL Certificate for iEmail Web Service (Optional)

Recommended if you will use iEmail outside your firewall or with a hosted iMIS database. Create a self-signed
certificate in IS and bind it to port 443 (HTTPS).

Step 5: Install the iEmail Client Outlook Add-in

Close Outlook completely before proceeding.

1. Right-click iEmail Client Outlook Add-in 3.X.XX.exe and select Run as Administrator.

2. If prompted to uninstall a previous version, select Yes.
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3. When asked about installing for all users or current user, select Yes for all users (typical).
4. Accept the licence agreement and follow the installer prompts.

5. Launch Outlook to confirm the iEmail toolbar is present.

Note: Silent install command: "iIEmail Client Outlook Add-in 3.X.X.X.exe" /S

Step 6: Create the License Role in iMIS

In the IMIS Staff site (as System Admin), go to Security > Roles and click Add a role. Create a role with the code
CSl-iEmail and save.

Step 7: Assign the CSl-iEmail Role to Licensed Users

In the IMIS Staff site go to Security > Users. For each licensed user, open the user record, click Add role under
User Information, select CSl-iEmail, and click OK.

Step 8: Add/Edit Email Activity Type in iMIS Desktop

Navigate to Customers > Set up Module > Activity Types. Click New to add or select an existing type to edit.
Set the Activity Type to EMAIL and save.

Step 9: Add/Edit Email Activity Type in iMIS Staff Site

Navigate to Settings > Contacts > Activity Types. Click Add new activity type (or click an existing type to edit).
Configure the EMAIL type and click Save & Exit.

5. Running iEmail for the First Time

1. Launch Outlook and start a new email.
2. Click the iMIS icon in the Outlook toolbar.

3. On the iEmail Login Screen enter your iMIS Logon, Password, and the iEmail Web Service URL (NOT the iMIS
Server URL). The URL must start with HTTPS://.

4. Click Logon. Your credentials are saved for future sessions.

Note: If Outlook disables the iEmail add-in, go to File > Manage COM Add-Ins, find iEmail Outlook COM
Add-in, and select Enable this add-in.

About the License Key

When you first log in, iEmail calls a CSI API to validate your license. If valid, it self-licenses. Without a license key,
iEmail can only connect to an iMIS Demo database. New-computer installations do not require re-entering the
license key.

6. Updating iEmail
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Each upgrade requires updates to both the client COM Add-in and the server web services (and the IQA web
services if installed). The first two version numbers (major.minor) must match between client and server.

Update order:
1. Close Outlook and confirm it is not running in Task Manager.

2. Run iEmail Client Setup.exe on the workstation and follow prompts.
3. On the server, run the iEmail Web Services Deployment installer and complete the wizard.
4. Launch the deployment tool from Start, click Validate Database (turns green), then click Update.

5. If using IQA: on the IMIS casual website server run the iEmail Web Services Deployment IQA Setup and click
Install to update.

7. Using iIEmail

7.1 Searching for Addresses

From a new email in Outlook, click the iMIS icon to open the iEmail Address Book. iEmail offers five search
methods:

Search Search by iMIS fields (Name, Company, ID, user-defined indexes, etc.)
Committee Browse and select from iMIS committees; filter by type, term, or sort order
Ad Hoc Run any Ad Hoc query stored in your iMIS database

Events Drill down by Event - Function - Registrants

Views Search using User Defined or System views that include an Email field
Query Architect (IQA) Browse IQA folder structure and run queries; requires IQA web service

After selecting recipients, click To, Cc, or Bcc to insert addresses, then click Save (or OK). Use Ctrl+A to select
all, or hold Ctrl to select individual records. Right-click the result grid for shortcut actions.

Note: If Ad Hoc search changes in iMIS are not reflected in iEmail, go to Options > Web System Setup and
click Recycle Application.

7.2 Creating an Email Activity in iMIS

Option 1 — Send and Insert simultaneously:

Use the Send/Insert Activity button (instead of the standard Send button). iEmail sends the email and opens the
Insert Activity window. Click Save.

Option 2 — Insert after sending or receiving:
1. Select the email in Outlook (inbox, sent, or any folder).
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2. Click the Insert Activity icon on the iEmail toolbar.
3. Choose which address box iEmail should search (From, To, or both).
4. Optionally enable Save Mail Message as EML file attachment.

5. Click Save, then Yes to confirm. iEmail creates an activity for each matched recipient.

Note: When replying or forwarding, pop the email out of the Reading Pane first (click the pop-out icon), then
use Send/Insert Activity — otherwise reply text will not appear.

7.3 Activity Field Mappings
In Options > Insert Activity Setup > Setup Activity Types, map email fields to iMIS activity fields:

[ Sent On] Date the email was sent

[ Subj ect ] Email subject line

[ Body] Full email body text

[ User nane] iMIS logged-in username

[ Reci pi ent s] Comma-separated list of all recipient addresses
[ Froni Sender address

[ To] To addresses

[ Cc] Cc addresses

[ Bec] Bcc addresses

[ Today] Current date (e.g. 4/12/2019 12:00 AM)

[ Nowj Current date and time (e.g. 4/12/2019 9:30 AM)

7.4 Creating an Email Interaction in iMIS

Click Create Interaction in the Outlook toolbar. In the Create Interaction window:

1. Review matched recipients on the Recipients tab. Unmatched addresses appear in 'E-mail Address Not
Found' — use Find to locate them.

2. Change the filter (To only / From only / From+To) as needed.

3. View the email on the Message tab; manage attachments with the Attachment button.
4. Optionally check Save Mail Message as EML file attachment.

5. Click Save then OK.

7.5 Syncing Tasks and Appointments

Import Tasks from iMIS to Outlook:
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Click Sync Tasks in Outlook. Select a task and click the Import icon. Click the Synchronize button to push
completed Outlook tasks back to iMIS.

Import Appointments from iMIS to Outlook:

Click Import Appointments in Outlook. Double-click an appointment to see details; click Import to add it to your
Outlook Calendar.

Insert Appointment Activity into iMIS from Outlook:

For a new meeting, click New Meeting in Outlook, optionally add attendees via iEmail, then click Insert Activity
before sending. For an existing appointment, open it and click Insert Activity.

8. System Setup

Access via Outlook > New Email > iMIS icon > Options > System Setup. Requires iMIS Sys Mgmt. authorization
level 8 — System Setup. Settings apply to all iEmail users.

Search Options Enable/disable Address Book tabs (Search, Ad Hoc, Committee, Events,
Views, IQA). Access Keywords override per user. Enable Primary Chapter
Search to use Name.Chapter instead of Subscriptions.

Search Filtering Define which Committees (or Committee Groups) and Views are available.
Move items to Hidden to remove them; move Views to Available to expose
them. Remove Views from iEmail before removing from SQL.

IQA Options Set the Root Path for the Query Architect tab (e.g.
$/ContactManagement/...). Narrower paths reduce the folder tree shown to
users.

Recipient Options Set the maximum number of recipients in To, Cc, and Bcc. CSI

recommends no more than 200 total.

Activity Insert Options Enable/disable Insert Activity, attachment saving, and Product Code
lookup. Use Activity Type Setup to map email fields to iMIS activity fields.

View Profiles Options Set the Profile URL for linking to iMIS Staff site member profiles.

Custom Access Keywords

| EM_ ADM N All tabs

| EM_SEARCH Search tab

| EM_ADHOC Ad Hoc tab

| EM COW Committee tab
| EM_EVENT Events tab
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| EM VI EWS Views tab
| EM | QA Query Architect tab
| EM_| NSACT Insert Activity function

9. Known Issues

« After inserting an address, the draft email is saved even if cancelled. Create an Outlook rule to delete
blank-body or blank-subject drafts automatically.

* Creating and then cancelling an Appointment may leave a blank meeting on your Calendar.

* When using Send/Insert Activity, some versions place a copy of the email in Deleted Items (the activity is still
created and the email goes to Sent Items normally).

10. Troubleshooting

Issue: Email attachments don't appear in Insert Activity, or exceeds file size limit.

Resolution: Contact your System Admin to verify Activity Attachments is enabled in iMIS Desktop (File > System
Setup) and the Max file size is adequate.

Issue: Error: 'Maximum request length exceeded' on Insert Activity.

Resolution: Add <httpRuntime maxRequestLength="20240" /> immediately after <system.web> in the iEmail
Web.Config file.

Issue: CSI Toolbar appears multiple times in Outlook.

Resolution: If Microsoft Word is your default mail editor, open Word > Tools > Templates and Add-Ins >
Organizer > Toolbars tab. Delete any CSI Toolbar entries, then restart Outlook.

Issue: 'There was no endpoint listening..." error on login.
Resolution: Verify the iEmail Web Service URL in Options > Connect to Web Service. In IIS, check that the
Application Pool is set to Integrated mode with .NET 4.0 framework.

Issue: iIEmail COM Add-in not visible after installation.

Resolution: Close Outlook. In Registry Editor, delete keys
HKCU\Software\Microsoft\Office\Outlook\Addins\CSI.iIEmail and
HKLM\SOFTWARE\Microsoft\Office\Outlook\Addins\CSI.iEmail. Re-open Outlook and go to File > Options >
Add-Ins to verify or re-add the add-in.

Issue: Cannot connect after upgrade to iMIS 2017.
Resolution: In the iIEmail Web Services Deployment tool, update the iMIS Web Server URL to use HTTPS. Also
check for 1IS Rewrite rules on the Default Web Site that may be inherited by iEmailWebServices.

Issue: Wrong bitness installed (redemption.dll error).
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Resolution: Uninstall iEmail and install the correct version for your Outlook bitness. Check Outlook bitness at File
> Office Account > About Outlook.

Web Service Verification Checklist

Use this checklist to systematically verify your iEmail web service installation:

1. Download the latest iEmail version from the ASI Product Download site.

2. Install and run the iEmail Web Services Deployment Tool on the app/web server.

3. Verify the web service from the server: browse to http://localhost/iEmailWebServices/Public.asmx — you
should see a web service page.

4. Identify the server name (right-click My Computer > Properties).
5. Verify from a workstation: browse to http://ServerName/iEmailWebServices/Public.asmx.

6. Verify the iMIS Membership Web Service: browse to
https://imis.yourorg.org/iMIS/AsiCommon/Services/Membership/MembershipWebservice.asmx.

7. Log into iEmail: click the iMIS icon, enter iMIS credentials and the web service URL (omit /Public.asmx from the
end).

8. If using 1QA, verify: http://localhost/DEMOIMIS/IEmail/QueryDetails.asmx.

11. Release Notes

3.2.7 Jul 2023 Add-In Express loader files digital signature; Outlook Redemption v6.4.0

3 2. 3 Jan 2023 Outlook Redemption v6.3.0

3.2.4 Jun 2022 Fix duplication of email addresses with multiple entries in the Email field

3 2. 8 May 2022 Remove per-device user lock; Add-in Express 10.1; Redemption 6.1; EMS on-prem support
3.1.30 May 2022 Installer fix for Outlook 2013 64-bit

3.1.29 Sep 2021 Outlook Redemption v6.0

3.1.27 May 2021 Reduce license expiration from 20 to 10 minutes

3. L. 25 Apr 2021 Outlook Redemption v5.27

3.1.22 Feb 2021 Redemption v5.26; 500-error handling; Add-In Express v9.5; simplified setup/zip
3.1.16 Jan 2021 Allow DELETE verb; disable WebDAV in web config

3.1.11 Jul 2020 Fix authentication issue with set-cookie on login

3.1.10 Jul 2020 Fix login issues from deprecated preferences

3.1.9 Jun 2020 Fix auth token expiration validation and renewal

3.1.0 Aug 2019 Multi-factor authentication support

3.0.1 Jan 2019 New major release; Interactions feature added
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2.5.39 Jun 2018 Location field support in Insert Appointment Activity

2.5.37 Mar 2018 New View Profile feature

2.5.33 Jan 2018 TLS 1.2 support; library updates

2.5.31 Jan 2018 Find/Search text on Committee tab; new system options for Committee/Task Data search
2.5.14 Aug 2016 Alternate authentication via membership web services; IQA fixes for iMIS 20.2.x

2.5.10 Dec 2015 Fix Outlook 2016 64-bit detection in setup launcher
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